LTC Degraded Performance
Incident Report for Fireblocks
Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 16:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2023 - 15:35 UTC
Investigating
We are currently investigating this issue.
Posted Mar 14, 2023 - 13:48 UTC
This incident affected: Blockchain nodes (Litecoin).