Cardano Degraded Performance
Incident Report for Fireblocks
Resolved
This incident has been resolved.
Posted Jun 28, 2022 - 14:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 28, 2022 - 13:29 UTC
Investigating
We are currently investigating this issue.
Posted Jun 28, 2022 - 12:48 UTC
This incident affected: Blockchain nodes (Cardano).