FB429U: Transaction processing issues with Exchange transactions

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 07:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2025 - 07:35 UTC

Investigating

We are currently experiencing an issue with Exchange integration that is causing transaction processing issues.
We are actively investigating this issue. This is not impacting all exchanges/regions.
Posted Jul 16, 2025 - 07:24 UTC