FB421U: Web3 Infrastructure Wallet Connect degradation

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 15:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 15:37 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 03, 2025 - 14:29 UTC

Investigating

Our Web3 infrastructure is currently experiencing an issue with Wallet Connect that is causing an issue with initiating dApp connections. We are actively investigating this issue.
Posted Jun 03, 2025 - 14:19 UTC
This incident affected: Web3 (Wallet connect).