Solana Transactions are blocked on Fireblocks Platform
Incident Report for Fireblocks
Resolved
This incident has been resolved.
Posted Jun 02, 2022 - 17:45 UTC
Update
We are continuing to investigate this issue.
Posted Jun 02, 2022 - 17:39 UTC
Update
We are continuing to investigate this issue.
Posted Jun 02, 2022 - 08:13 UTC
Investigating
On June 1, 2022, the Solana network was shut down due to a bug in its node software. Solana Labs introduced a temporary fix after a few hours and resumed network activity. However, as part of the temporary fix, they stopped processing durable nonce transactions until a further change in the node.
This type of transaction is critical for all platforms that use offline and asynchronous signing. Without it, transactions must refer to blocks that have been submitted in approximately the last 2 minutes, depending on network conditions. Therefore, your transactions on Solana may take more than 2 minutes to complete since Fireblocks requires its users to manually sign transactions, which sometimes takes more than 2 minutes.
As the timeline of fully resolving the issue is beyond our control, we developed an alternate implementation that uses non-durable nonce transactions. We deployed this solution at 1:20 PM EST on Thursday, June 2, 2022.
Note that your Solana withdrawals will resume, but with a 90-second time limit for signing. We cannot guarantee transactions signed outside the 90-second window will be sent on time.
If you have any questions or need additional support, contact Fireblocks Support.
For status updates on the issue, we recommend checking Solana Labs’ official GitHub.
Posted Jun 02, 2022 - 08:12 UTC
This incident affected: Blockchain nodes (Solana).