FB442U: Issue with outgoing transactions

Incident Report for Fireblocks

Resolved

A fix has been implemented and the issue is now resolved
Posted Aug 18, 2025 - 12:10 UTC

Identified

Our transaction processing infrastructure is currently experiencing an issue that is causing transactions to get stuck on BROADCASTING status. We are actively investigating this issue.
Posted Aug 18, 2025 - 11:50 UTC
This incident affected: Transactions engine.