FB524U: Intermittent delays with updating transaction statuses and balance on Fireblocks console

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 16:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 16:29 UTC

Update

Transactions are being signed and processed as expected on-chain - the issue is isolated to the web console only.
We are actively investigating this issue.
Posted Jun 02, 2026 - 16:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 02, 2026 - 16:14 UTC

Investigating

Our Fireblocks web console is currently experiencing an issue that is causing Intermittent delays with updating transaction statuses and balance.

We are actively investigating this issue.
Posted Jun 02, 2026 - 16:14 UTC
This incident affected: Web console.