Degraded infrastructure performance
Incident Report for Fireblocks
Resolved
This incident has been resolved.
Posted Dec 05, 2022 - 22:02 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 05, 2022 - 21:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2022 - 21:06 UTC
Identified
An issue with our cloud providers has been identified, resulting in degraded Fireblocks infrastructure performance.

https://health.aws.amazon.com/health/status
Posted Dec 05, 2022 - 20:33 UTC
Update
We are continuing to investigate this issue.
Posted Dec 05, 2022 - 20:07 UTC
Investigating
Fireblocks infrastructure is currently experiencing degraded performance which is affecting transaction processing and slow console response. We are actively investigating this issue.
Posted Dec 05, 2022 - 20:01 UTC
This incident affected: Web console, Fireblocks mobile app, and API.