FB530U: Transactions issues with outgoing transactions

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 15:14 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 22, 2026 - 14:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 14:53 UTC

Identified

The issue has been identified as part of the transaction serialization, and the fix is being implemented.
Posted Jun 22, 2026 - 14:47 UTC

Update

Our transaction processing infrastructure is currently experiencing an issue which is causing a delay in finalizing the transaction status. Symptoms include delayed notification for transactions approvals on Mobile device and cosigner and also transactions stuck in "Pending Signature" state. We are actively investigating this issue.
Posted Jun 22, 2026 - 14:32 UTC

Investigating

We are currently investigating this issue.
Posted Jun 22, 2026 - 14:24 UTC
This incident affected: Transactions engine and API co-signer.