ADA Degraded Performance
Incident Report for Fireblocks
Resolved
This incident has been resolved.
Posted Jul 02, 2022 - 10:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2022 - 09:58 UTC
Investigating
We are currently investigating this issue.
Posted Jul 02, 2022 - 09:40 UTC
This incident affected: Blockchain nodes (Cardano).