FB525U: Intermittent delays with TON transactions

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 15:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2026 - 15:18 UTC

Identified

Our TON transaction processing infrastructure is experiencing an issue that is delaying incoming transaction notifications, and stalling of outgoing transactions.

We are actively investigating this issue.
Posted Jun 03, 2026 - 14:49 UTC
This incident affected: Blockchain nodes (TON).