FB502U: Outgoing Solana transactions fail with INTERNAL_ERROR status

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 19:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 19:22 UTC

Identified

Our transaction processing infrastructure is currently experiencing an issue that is causing Solana transactions to fail with INTERNAL_ERROR
Posted Mar 17, 2026 - 19:10 UTC
This incident affected: Blockchain nodes (Solana).