Bittrex Integration issues
Incident Report for Fireblocks
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 19:55 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 14, 2022 - 18:29 UTC
Identified
Users may experience issues connecting a Bittrex exchange account, depositing or withdrawing assets from their connected Bittrex exchange accounts.
Posted Jun 14, 2022 - 18:29 UTC