Issues with logging-in to Fireblocks Console
Incident Report for Fireblocks
Resolved
This incident has been resolved.
Posted Jul 06, 2022 - 12:41 UTC
Investigating
We are currently investigating this issue.
Posted Jul 06, 2022 - 12:33 UTC