XTZ Degraded Performance
Incident Report for Fireblocks
Resolved
This incident has been resolved.
Posted Jun 28, 2022 - 22:35 UTC
Investigating
We are currently investigating this issue.
Posted Jun 28, 2022 - 22:15 UTC
This incident affected: Blockchain nodes (Tezos).