FB416U: Authentication & Transaction processing issues with Fireblocks Console & API

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 07:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2025 - 07:38 UTC

Investigating

Our authentication infrastructure is currently experiencing an issue that is causing login failures for both Console & API Users. This is impacting transaction processing as well.
Posted Apr 21, 2025 - 07:32 UTC
This incident affected: Transactions engine, Web console, User authentication, and API.