FB393U: Intermittent delays with updating balance on Fireblocks console

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Jan 21, 2025 - 18:50 UTC

Investigating

Our Fireblocks console is currently experiencing an issue that is causing Intermittent delays with updating balance on Fireblocks console. We are actively investigating this issue.
Posted Jan 21, 2025 - 18:38 UTC
This incident affected: Web console and Wallet management.