FB513U: Transaction processing delays with Litecoin transactions

Incident Report for Fireblocks

Resolved

The Incident has been resolved.
We are actively monitoring the Litecoin chain itself for any other stability issues.
Posted Apr 25, 2026 - 13:13 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
In addition, we have identified an issue with the Litecoin chain itself where new blocks are being created with massive delay.
Posted Apr 25, 2026 - 13:06 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 25, 2026 - 12:31 UTC

Investigating

Our transaction processing infrastructure is currently experiencing an issue that is causing a delay in finalizing the transaction status of Litecoin blockchain. We are actively investigating this issue.
Posted Apr 25, 2026 - 12:24 UTC
This incident affected: Blockchain nodes (Litecoin).