DOT Degraded Performance

Incident Report for Fireblocks

Resolved

This incident has been resolved.
Posted Mar 17, 2023 - 08:40 UTC

Investigating

We are currently investigating this issue.
Posted Mar 17, 2023 - 08:30 UTC
This incident affected: Blockchain nodes (Polkadot).