We are experiencing delays restoring full service for the ZCash blockchain, we are investigating this now, and will restore functionality as soon as possible.
Posted Apr 23, 2025 - 16:19 UTC
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 23, 2025 - 15:43 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 23, 2025 - 15:00 UTC
Scheduled
ZCash Mainnet will perform an upgrade on April, 23, 2025. The upgrade will be completed once the network’s nodes finish upgrading. A short while before that time, Fireblocks will halt all activities on the ZCash blockchain, as the network may be disrupted during the upgrade, which is expected to last roughly 1 hour. Once the upgrade is completed, Fireblocks will re-enable the activity.
Posted Apr 23, 2025 - 14:03 UTC
This scheduled maintenance affected: Blockchain nodes (Zcash).